Old version plugins always pose security risks and stability issues to any Browser, Mozilla is blocklisting these type of add-ons to protect users from using it, you can always check updates for your plugins using Mozilla plugin check, install them if update found and suggested by the page. Mozilla today has announced in their add-ons blog that they’ve added old versions of Silverlight plugin for Mac OS X to their blocklist, if you’re a Mac user using Silverlight plugin version older than v 5.1 in Firefox it is recommended to you to disable it immediately.

You can either visit plugin check page offered by Mozilla in Firefox browser to check for updated version of Silverlight or download latest version from Silverlight site.

Mozilla blocked Silverlight plugin for causing stability issues like crashing Firefox on popular sites like Hotmail. So if you’re experiencing Firefox crashes first download and install Silverlight 5.1 on your computer.

This plugin will be automatically disabled by Firefox, however you can enable and use it at your own risk which is not recommended.