Google Chrome _logo

Google always trying to offer more security for Chrome users, as you know Google Chrome already protects users with sandboxing technology, and with default enabled malware and phishing protection, Google added two more features to  Google Chrome labs to disable outdated plug-ins, XSS Auditor for protection against cross-site scripting attacks from malicious websites .

Few months back Google integrated Flash player plug-in into Google Chrome and there are advantages of it being Google Chrome automatically updates flash player plug-in whenever new version is released this is to protect from outdated plug-ins, always pose security risk that too with use of flash player plug-in, Google already stated that soon Chrome will block outdated plug-ins and then help the users to update them.

Enable Disable outdated plug-ins, XSS Auditor

Enable “Disable outdated plug-ins” and XSS Auditor features in Chrome

1.If you are using latest canary build type about:labs in Chrome’s Omnibox.

2.Enable these features, you need to restart Chrome to enable each feature.

By enabling Disabling outdated plug-ins Google Chrome automatically disables outdated plug-ins with known security vulnerabilities and offers update links for them.

By enabling XSS Auditor enables WebKit’s XSS Auditor (cross-site scripting protection).This feature aims to protect you from certain attacks of malicious websites.It improves your security,but it might not be compatible with all web sites.

Google Chrome labs features are experimental features.