Adobe Flash Player

Adobe released Security bulletin mentioning that vulnerabilities are found in Adobe flash player 10.0.32.18 and earlier versions.These vulnerabilities could cause the application to crash and allows an attacker to take control of affected system. Adobe recommends all users to update their flash player to Flash Player version 10.0.42.34 .

Read the article 3 Ways to Check Flash Player Version Installed in Your Browser to check flash player version installed in your computer. Easiest way to check is visiting Flash player about page.

Though Mozilla plugin check will show the plug-ins update status installed in Firefox, but presently it is showing flash player status as up to date. So users better update their flash player to latest version to get protected from vulnerabilities. Users can install latest flash player version for Firefox browser for IE,and other browsers visit Flash player download center page and follow the instructions on the screen.

flash player installed

Adobe also recommends user to update from Adobe AIR 1.5.2 to ADOBE AIR version 1.5.3.

Related articles